Subscription Calendar Issue with Google Calendar

Incident Report for AddEvent

Identified

Workaround solution: We have implemented a workaround that provides clear instructions for manually subscribing to calendars in Google Calendar.

- When users click “Add to Calendar” → “Google,” instead of taking them directly to Google Calendar, we’re now directing them to Google’s manual import.

-Try it yourself here:
https://www.addevent.com/calendar/ih348885

This temporary solution has been automatically implemented. When Google resolves this bug, we will revert to the normal subscription process for Google Calendar users.
Posted Sep 04, 2025 - 20:56 UTC

Investigating

We are aware of an issue affecting Google Calendar’s ability to fetch subscription calendar feeds. At this time, new subscriptions (initial calendar imports) are unavailable in Google Calendar until Google resolves the problem.

We’ve reported this bug to Google and encourage you to do the same.

Thank you for your patience. We’ll continue to monitor the situation and share updates as they’re available.
Posted Sep 02, 2025 - 20:45 UTC